Getting Stryd Power Zones to Show on Garmin

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #18416
    katstan
    Participant

    Hi all,

    I’d been using an 8020 Marathon Level 0 HR based plan successfully on my Garmin 245. I just got a new Stryd on Friday and tried to set it up to work with Training Peaks and my Garmin and while I have figured out how to get power to show on one of the data screens, I can’t get it to show up with the recommended zones for a workout like it did for heart rate. Basically, at this point I’d need to memorize the zones to get it to work. Any advice for how to get this to show? I currently have 8020 zones installed in addition to stryd zones through Garmin IQ. I’ve followed all of the instructions for getting everything set up for Stryd and I even tried uninstalling the 8020 zones and the Stryd Zones and installing them separately and together and nothing seems to work 🙁 Disappointed and wondering if I need to switch to a Stryd training plan now to make this all seamless.

    I did do the ftp 20 min test and updated my 3 running zones in training peaks and turned off the automatic CP setting in Stryd.

    • This topic was modified 1 year, 3 months ago by katstan.
    #18418
    Gerald
    Participant

    The Garmin does not allow Stryd Power to shown on the native Garmin workouts like HR. The typical work-around is to use the Stryd Workout App to use the TP structured workouts. Actually, they work very well.

    #18419
    katstan
    Participant

    Hmm, just tried installing this. Still not showing :(.

    #18420
    Gerald
    Participant

    Hmm,

    1) Do the TP workouts show on the Stryd Calendar?

    2) Have you set your lactate threshold powet as a manual CP?

    3) Where you able to get the workouts to load on the watch?

    3a) Did you enter the stryd username in settings?

    #18421
    Charles
    Participant

    I frequently switch between heart rate, pace, and power. I have found it necessary to manually sync to assure the Stryd App, Garmin and Training Peaks are processing everything in a timely manner.

    1. On the Stryd App on my phone I will go to the Connected Accounts / Training Peaks and manually sync workouts. This assures that the workout will be available immediately, else you may be waiting for an undetermined time.

    2. On my watch I select the Stryd Workout App. (I have both the Stryd Workout App and the Stryd Zones Data Filed installed). If I am using pace or heart rate I use the data field to check power occasionally with a swipe, otherwise for power workouts the Stryd App.

    3. When selected the Stryd App will show a workout menu selection. You must first fetch workouts to the watch – have your phone nearby. Then select the workout. You should be good to go with you 80/20 power zones at that point. Just to be clear, 80/20 and Stryd zones are different; I ignore the Stryd Zones and stay with the 80/20 zones – they show correctly on the watch; I suspect that if you start using the Stryd Workouts your zones will be out of sync with your 80/20 workout plan.

    If you are still having problems there are some configuration notes about connecting the footpod on the support page https://support.stryd.com/hc/en-us/categories/360001374593-Stryd-Setup-for-Garmin-Watches

    #18422
    Gerald
    Participant

    To add to Charles great answer
    The 80/20 threshold and Stryd CP must match for the zones to work correctly in my experi2nce.

    #18423
    katstan
    Participant

    I think I got it guys. Thanks for all your help. Turns out the workouts app wasn’t downloading on the phone no matter how many times I tried a o I had to put it on through garmin express. That plus some more playing around with settings and putting my username in the settings on the workouts app on the watch itself, seems to have done the trick. Looking forward to using it on my long run tomorrow.

    #18424
    Gerald
    Participant

    Glad we could help.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.
Posted in

katstan

You must be logged in to create new topics and to reply to topics.